Select an environment

Cancel
  Log On
aiSmartBench
Company:
Mentis Technology LLC.
Version: 2016.05.10.1
Publisher: aiREMOTE
The following prerequisites are required:
 
  • .NET Framework 4.0
If these components are already installed, you can launch the application now. Otherwise, click the button below to install the prerequisites before launching the application.

These components are also available on Windows Update
 

Install Prerequisites